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PREFACE

Every effort has been made to ensure that the information in this document is complete,
accurate, and up-to-date. The manufacturer assumes no responsibility for the results of
errors beyond its control. The manufacturer also cannot guarantee that changes in software
and equipment made by other manufacturers and referred to in this guide will not affect
the applicability of the information in it. Mention of software products manufactured by
other companies does not necessarily constitute endorsement by the manufacturer.

While all reasonable efforts have been made to make this document as accurate and helpful
as possible, we make no warranty of any kind, expressed or implied, as to the accuracy or
completeness of the information contained herein.

The most up-to-date drivers and manuals are available from:
http:/ /www.okiprintingsolutions.com
Copyright © 2015. All rights reserved.
OKI is a registered trademark of Oki Electric Industry Co., Ltd.
Oki Printing Solutions is a registered trademark of Oki Data Corporation.
Microsoft, MS-DOS and Windows are registered trademarks of Microsoft Corporation.
Apple, Macintosh, Mac and Mac OS are registered trademarks of Apple Computer.

Other product names and brand names are registered trademarks or trademarks of their
proprietors.
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NOTES, CAUTIONS AND WARNINGS

NOTE
A note provides additional information to supplement the main text.

CAUTION!

A caution provides additional information which, if ignored, may
result in equipment malfunction or damage.

A warning provides additional information which, if ignored, may
result in a risk of personal injury.
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NETWORK CONFIGURATION

INTRODUCTION

Your machine incorporates a fast 100BASE-TX/10BASE-T network interface. This guide
explains the functionality of the built in network interface. Access for interconnection is
provided via an interface panel at the rear of the machine.

This network interface supports IEEE802.2, IEEE802.3, Ethernet-II and SNAP, and can
detect those frame types automatically.

Also, the interface supports major protocols such as TCP/IP, IPX/SPX (NetWare) and
NetBEUI.

This guide details the network interface specification and several software utilities.

You should set the emulation in the printer menu settings to Auto or PS before printing the
configuration map.

NOTE
Not all utilities, features or protocols are supported by every operating
system. Please check with your support website for latest information.
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SPECIFICATION

Frame Types IEEE 802.2
IEEE 802.3
Ethernet-1I, SNAP, AUTO

Network Interface 100BASE-TX
10BASE-T
Network Protocols TCP/IP V4, V6
IEEE 802.1x
Network layer: ARP, IP, ICMP
Session layer: TCP, UDP

Application layer:LPR, FTP, TELNET, HTTP, IPP,
BOOTP, DHCP, SNMP, DNS, SMTP, POP3, SLP,
Bonjour

IPX/SPX (NetWare)

Remote printer mode (up to eight file servers
and 32 queues)

Print server mode over IPX/SPX (up to eight
print servers)

Encrypted password supported in print server
mode

EtherTalk
NetBEUI
NetBIOS, WINS
SSL/TLS
IPSec
Functions Self-diagnostic test printing
Banner supported
Monitoring and configuration by Web browser
Printer status notification by E-Mail

NOTE
Not all utilities, features or protocols are supported by every operating
system. Please check with your support website for latest information.

CONFIGURATION SETTINGS

With the machine power switched on, print out the configuration map:
1. Press the Enter button.

2. Press the Menu down button then the Enter button to select the print
Information menu.

3. Select Configuration with the Enter button.
4. Press the Enter button once more to execute the Configuration menu.
5. When the Configuration map is printed, press On Line to exit the menu system.

On the first page of the Network Information that is printed out, under the heading “"General
Information” the MAC Address is given. For example:

MAC ADDRESS 00808784E3F1
The Ethernet address is therefore: 00:80:87:84:E3:F1
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CONFIGURATION UTILITIES

You can configure the network interface (NIC) by using one of the following methods:

UTILITY FEATURES SYSTEM REQUIREMENTS
Network Card Configure the NIC easily and Windows:
Setup simply without installing any Windows 10 32-bit

software packages into your Windows 10 64-bit

system. You can set the Windows Server 2012 R2

following: Windows 8.1 32-bit

> Set IP address, Subnet Mask Windows 8.1 64-bit

and Gateway for TCP/IP Windows Server 2012

lly or by using DHCP.
manually or by using Windows 8 32-bit

Windows 8 64-bit

Windows Server 2008 R2
Windows 7 32-bit

Windows 7 64-bit

Windows Server 2008

Windows Server 2008 x64 Edition
Windows Vista 32-bit

Windows Vista 64-bit

Mac:
Mac OS X 10.8.5 - 10.11

Web Browser Configure the NIC and printer Microsoft Internet Explorer or similar.

by using a Web browser such | operating system that supports Web
as Microsoft Internet Explorer browser.

or Mozilla Firefox.

Telnet Configure the NIC using Third-party vendor developed TELNET
TELNET. client package.

SNMP The machine and network Third-party vendor developed SNMP
card can be controlled using application.

third-party vendor developed
SNMP application.

USING NETWORK CARD SETUP
You can use Network Card Setup to configure the network.

In order to use Network Card Setup, TCP/IP needs to be activated.

NOTE
Administrator privileges are required.

LAUNCHING THE UTILITY
1. Insert the Software DVD-ROM into your computer.
2. Click Run Setup.exe.
If the User Account Control dialog box appears, click Yes.
.  Select the appropriate language.
Read the user license agreement and click on I Agree.
Select Network Software.
Click Network Card Setup.

o u AW
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CONFIGURING NETWORK SETTINGS

nohwN

Launch Network Card Setup.

Select the printer from a list.

Select Setting Printer from the Setting menu.

Change the items required and click on OK.

Enter your password into Enter Admin password and click on OK.

> The default password is the last 6 alphanumerical digits of the Ethernet address.
> The password is case sensitive.

Click OK on the confirmation window.

The new settings are enabled when the printer restarts. During the restart, the printer
status icon changes to red. The printer will restart, the new settings will become
active, and the status icon will turn green.

CONFIGURING WEB SETTINGS

You can launch the web page to configure the printer’s network setting.

Enabling Web Settings

ok whNRH

Launch Network Card Setup.

Select the printer from the list.

Select Setting Printer from the Setting menu.

Select the Printer Web Page tab.

Select Printer Web Page - Enable and click on OK.

Enter your password into Enter Admin password and click on OK.

> The default password is the last 6 alphanumerical digits of the ethernet address.
> The password is case sensitive.

Click OK on the confirmation window.

The new settings are enabled when the printer restarts. During the restart, the printer
status icon changes to red. The printer network card will restart, the new settings will
be active, and the status icon will turn green.

Opening the Web Page

1.
2.
3.

Launch Network Card Setup.
Select your printer from the list.
Select View Web Page from the Setting menu.

The web page will start, and the printer status page will be displayed.
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CHANGING THE PASSWORD

W

6.

Launch Network Card Setup.

Select your printer from the list.

Select Change Password from the Setting menu.

Enter the current password.

> The default password is the last 6 alphanumerical digits of the ethernet address.
> The password is case sensitive.

Enter the new password, and reenter it for confirmation.

The password is case sensitive.

Click OK on the confirmation window.

CHANGING THE ENVIRONMENT

You can configure the printer search conditions, time-out value for each setting, and items
to be displayed on the list.

1.

2
3.
4

Launch Network Card Setup.
Select your printer from the list.
Select Environment Settings from the Option menu.

Configure the settings required and click OK.
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USING A WEB BROWSER

If the printer is connected to the network using TCP/IP, its settings and the printer menu
settings can be configured using a Web browser. Refer to the relevant manuals for details
of how to launch and use the browser.

MICROSOFT INTERNET EXPLORER
1. Select Internet Options in the Tools menu.
2. Click on the General tab and click Settings in Temporary Internet files.

3. Select Every visit to the page in Check for newer versions of stored pages.

DEFAULT USER NAME AND PASSWORD

To apply configuration changes using a Web browser, you will be prompted for a username
and password. The username is admin and the default password is aaaaaa.

The admin password can be changed to allow you to configure the printer by using a Web
browser/TELNET. To change the password, select Password Configuration in the
Maintenance tab and follow the on-screen instructions.

ADJUSTING PRINTER SETTINGS

The network addresses used in this manual are shown as examples only. Network
addresses used in your installation must be generated from your own network.

1. Configure the IP Address, Subnet Mask and Gateway for the network card. Launch
the Web browser, enter the IP Address of the network interface card in Address
(Location/Position) and press the Enter key.

2. Select a tab and items to be changed in the left frame. You need to log in as admin
to be able to configure all items. Non-admin users cannot configure all items.
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UsING TELNET

Please ensure a valid IP address for your network environment is
used. Use of an incorrect IP address can cause serious problems on
your network.

EXAMPLE TELNET CONFIGURATION

TELNET requires the print server to have a valid IP address configured. If the NIC already
has an IP address configured, skip steps 1 to 3 below.

3.

NOTE
The method of configuring commands may differ between workstations. Refer
to the workstation’s manual.

Use the PING command to confirm the connection with the network card.
Example

For IP address 172.168.20.127:

ping 172.168.20.127

If there is no reply, there is a problem with the configuration of the IP address (the
IP address has been already set manually or by the DHCP/RARP server), or with the
network. Reset the network interface card settings to the default and try to set a
temporary IP address. If you still have the problem after resetting the network
interface card, consult the network manager.

Login to the network card using TELNET.

Example

For IP address 172.168.20.127

telnet 172.168.20.127

You should see a sequence similar to the following example:

Trying 172.168.20.127

Connected to 172.168.20.127

Escape character is ‘"]'.

EthernetBoard 8450e TELNET server (Ver 01.01).
login: admin

‘admin’ user needs password to login.

password:

User ‘admin’ logged in.

No. MENU (level.l)

l:Status / Information
2:Device Config
3:Network Config
4:Security Config
5:Maintenance

99:Exit setup
Please select (1-99)?

Enter the number of the item to be changed.

The details window for that item displays.
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4. When the configuration is complete, select Exit Setup to save your change. To exit
without saving your modification, select Quit.

5. Turn the machine off and on again.

NOTE
The network card continues to use pre-transmission settings until the machine
is turned off and back on again.
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USING SNMP

NOTE
Not all utilities, features or protocols are supported by every product. Please
check with your support website for latest information.

The machine and network card can be managed via a standard SNMP management station.
The network card supports SNMPv1, MIB-1I, Oki Data Private MIB and SNMP V3. In order
for the machine to be managed correctly from an SNMP management station, the Oki Data
Private MIB needs to be added to that management station. Please refer to the SNMP
manager documentation for information on how to do this.

NOTE

The Oki Data Private MIB file can be found in the \Misc\ASN folder on the
DVD-ROM or support website. Please refer to the readme file for further
information.

The printer’s trap address can be set in five places using TCP/IP and in one place with IPX.

Printer trap settings can be made with TELNET and a Web browser.

PRINTING UTILITY — OKI LPR

NOTE
Not all utilities, features or protocols are supported by every product. Please
check with your support website for latest information.

The Oki LPR Utility is a utility that allows printing data to printers connected to the network
via TCP/IP.

The utility is for those Oki printers which support TCP/IP and redirects printing data to the
Ipr port of the specified IP address.

It is an alternative method of connecting printers instead of using the Microsoft TCP/IP port.

SYSTEM REQUIREMENTS
Operating Systems with TCP/IP support and Oki printers that support TCP/IP.
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INSTALLING THE OKI LPR UTILITY

® NoO U AW

10.

11.

12,
13.
14.
15.

16.

NOTE
Some Operating Systems require administrator privileges in order to make
changes.

Set up the printer driver by designating the output destination to Local Printer
(LPT1:). For information on setting up your printer driver, see the Printing Guide.

Insert the DVD-ROM into the DVD-ROM drive. The Setup Utility starts automatically.
If it does not start, double-click setup.exe on the DVD-ROM.

Select Network Software.

Select Install LPR.

Follow the on-screen instructions.

Click Next when the Welcome screen is displayed.

Verify Destination Folder and Spool Folder and click Next.

Check Register in Startup if you want automatic startup as Windows boots up.
Check Launch as minimized if you want to startup in the Icon state and click
Next.

Verify the program folder name and click Next. The installation starts.

When the installation ends, the Setup complete screen is displayed. Check Yes, I
want to launch Oki LPR Utility now and click Finish. Check Yes, I want to view
the ReadMe File if you want to read Readme. The OkiLPR utility will start.

You may be asked whether it is OK to change write permissions for the spool
directory. Click Yes to allow the utility to be correctly installed.

Select Add Printer on the Remote Print menu.
Click Discover... to search for the IP address of a suitable printer on your network.
Highlight the printer you will use and click OK.

If your printer is not discovered, click Cancel and you can type the IP address
directly at IP Address:.

Enter an IP address at IP Address and click OK. A printer is added to the main
window.

Refer to the On-line Help for information on how to use the utility.

UNINSTALLATION

1. Stop the OkiLPR Utility.

2. Select Start > All Programs > Okidata > OkiLPR Utility > Uninstall OkiLPR
Utility.

3. Click Yes when the Confirm File Deletion dialogue is displayed. Deletion of the
OKkiLPR utility starts.

4. When the deletion has finished, the Uninstall Complete screen is displayed. Click OK.

If a file that has been added after installation exists in the folder to install the OkiLPR utility
or the folder to spool, you cannot delete the folder. Delete any unwanted files before
running Uninstall OkiLPR Utility.
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MICROSOFT WINDOWS

OVERVIEW

This chapter provides guidelines on how to print over the network from various Microsoft
Windows platforms. There are numerous ways of printing from Windows and the exact set-
up will vary depending upon your environment. There are also numerous versions of
Windows, which can be configured as either a client, server or both.

Although there are many variants of Windows, the principles of network printing are the
same. Microsoft provides on-line help with all of their operating systems and this is a good
reference point for the exact details of each configuration option within Windows.

NOTE
Not all utilities, features or protocols are supported by every operating
system. Please check with your support website for latest information.

INSTALLING A NETWORK PRINTER

There are two ways to set up a Network Printer:
> Install automatically, using the Oki Driver Installer
> Install it yourself using the Add Printer Wizard

USING THE OKI DRIVER INSTALLER

The Oki Driver Installer program searches for compatible printers on the Network, then
installs and configures the printer drivers with the correct port settings automatically.

Using the Oki Driver Installer program, you can install to the following connected printer
types:

1. Locally connected printers
> USB port
2. Networked printers
> Directly connected (peer-to-peer) printers via TCP/IP

The Microsoft standard TCP/IP is installed and configured to use Port 9100 with the
printer’s IP address.

> Printers not directly connected, but shared via a PC (Client Server)
Why use the Oki Driver Installer?
> Automatically discovers printers on the Network (TCP/IP)
> Installs driver and correctly assigns the appropriate port and IP address
> Allows easy configuration and sharing of the printer with other Network users
>

Automatically configures the printer driver with the appropriate hardware device
options such as a storage device, additional paper trays, etc. (via the Oki Network
Extension software)
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USING THE ADD PRINTER WIZARD

About the different methods
Windows standard TCP/IP port

The standard TCP/IP port simplifies connecting to remote printers using the TCP/IP
protocol. A computer that acts as a print server must run the TCP/IP protocol in order to
print.

Can be configured to use either LPR or RAW (e.g. Port9100).
OkiLPR
Used to connect your printer over TCP/IP using an LPR port.

OKiLPR also includes useful tools enabling you to download PS and PRN files directly to your
printer and automatically redirect jobs to other printers on the network.

IPP

The IPP (Internet Printing Protocol) defines a standard protocol for printing as well as
managing print jobs, media, resolution, etc.
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MAc OS X

OVERVIEW

This section of the guide is for administrators and it should be read in conjunction with the
relevant Mac OS X manual. Please ensure your Mac has the latest OS X updates installed.

To get the best results from your printer, install the Postscript Printer Description (PPD) file
supplied with your printer and use this to customise the Apple PostScript driver that is built
in to the OS X. Features provided by the PPD file include:

> Supported paper types
> Paper trays

> Printer resolution

>

Printer color matching

NOTE
The PPD file must be installed using the Oki Driver Installer to ensure that all
essential files are copied.

SETTING UP A NETWORK PRINTER

1. If the printer does not already have an IP address, use the Printer Setup Utility to
assign an IP address.

To do this, you will need to know the printer's MAC address. This can be found on the
print server's network summary printout. See “Configuration settings” on page 6.

2. Install the printer driver software. This copies the printer driver files to the correct
location on your Mac OS X system.

3. Make a connection to the printer by USB, TCP/IP. See “Connecting to your printer”
on page 19.

4. If required, enable hardware device options such as additional paper trays or a
storage device.

USING NETWORK CARD SETUP

You can use the Network Card Setup to configure the network.
In order to use Network Card Setup, TCP/IP needs to be activated.

NOTE
Configure the TCP/IP settings.

LAUNCHING THE UTILITY

1. Insert the Software DVD-ROM into your computer.

2. Double click on the OKI > Utilities folder.

3. Copy the folder you want to install by dragging and dropping to the folder you want.

MEMO
To launch, double click on the utility icon within the folder.
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CONFIGURING THE IP ADDRESS

ui kW

Launch Network Card Setup.

Select the printer.

Select IP Address... from the Printer menu.

Configure the settings if necessary and click Save.

Enter the password and click on OK.

> The default password is the last 6 alphanumerical digits of the Mac address.
> The password is case sensitive.

Click on OK to activate the new settings.

Restart the printer network card.

CONFIGURING WEB SETTINGS

You can launch the web page, and configure the printer network settings.

Enabling Web Settings

1.
2.
3.

4.

Select Web Page Settings... from the Printer menu.

Select Enable and click on Set.

Enter your password into Enter Password and click on OK.

> The default password is the last 6 alphanumerical digits of the Mac address.
> The password is case sensitive.

Click OK on the confirmation window.

Opening a Web page

1.
2.
3.

Launch Network Card Setup.
Select the printer.
Select View Web Page from the Printer menu.

The web page will start, and the printer status page will be displayed.

QUITTING NETWORK CARD SETUP

1.

Select Exit from the File menu.
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CONNECTING TO YOUR PRINTER

If you have not already done so, run the Oki software installer before following the steps
below.

Mac 0SX

usB
1. Choose Apple Menu > System Preferences > Print & Fax.

2. If the printer is already in the list of printers, click “-” to remove it.

NOTE
This is necessary as Leopard may not be using the correct printer driver files.

3. Click “+” to add a new printer.
4. Ensure the Default tab is selected and select your printer from the list.
> Your printer is displayed as type USB in the list of available printers.

> Ensure that the Print Using: selection matches your printer. If Generic
PostScript Printer is displayed, select a driver that matches.

5. Click Add.

6. Click Configure... and ensure the hardware options displayed match your printer.

NOTE
Hardware options are not configured automatically.

The printer is added to the list of printers.

7. Restart your computer.

Bonjour

1. Choose Apple Menu > System Preferences > Print & Fax.

2. Click “+".

3. Select your printer model from the Default Browser.

4. Click Add....

5. Depending on the connection type, you may be prompted to configure any additional

printer hardware options. If your printer has options such as a storage device or
second tray, switch on the relevant options.
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TCP/IP Connection

1.

widwN

o

Choose Apple Menu > System Preferences > Print & Fax.
Click “+".

Click the IP Printer button.

From the Protocol menu, choose Line Printer Daemon - LPD.
Enter the printer's IP address in Address.

To find the printer's IP address, you can print a configuration page from the printer's
operator panel. Refer to “"Configuration settings” on page 6.

Check the correct PPD file for your printer is selected in the Print Using menu.
Click Add.

You will be prompted to configure any additional printer hardware options. If your
printer has options such as a storage device or second tray, switch on the relevant
options.
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TROUBLESHOOTING

The network addresses used in this manual are shown for example only. Network addresses
used in your installation must be generated from your own network.

TCP/IP

COMPUTER CANNOT FIND THE NETWORK INTERFACE CARD
Turn the printer off for 15 seconds and then on again.
Confirm the network interface is enabled on the printer.
Check there is a response to the PING command.

Check that the network cable is correctly connected and that the green LED close to the
printer’s network interface is lit. If not, change the cable and try again.

Run the self-diagnostic test.

Check the IP Address, Subnet Mask and Gateway are correct.

Check that the TCP/IP protocol is set to Enable.

Reset the network interface card to factory default settings.

If DHCP, BOOTP and RARP are not used, ensure they have been set to Disable.

CANNOT PRINT WITH LPR AND FTP

Turn the printer off for 15 seconds and then on again.

Check there is a response to the ping command.

Check the network cable is correctly connected.

Change the cable and try again.

Check the host name and IP address are configured in the workstation.
Check the printer port name is configured in the workstation.

There are three port names: Ip, euc and sjis. Use Ip by default as euc and sjis are specific
to PostScript printers.

INCORRECT USER NAME ON THE BANNER PAGE

If printing with Ipr, the user name printed is unknown and the filename printed is the Spool
file name.

If printing with FTP, the user name printed is the user name entered during FTP login and
the file name printed is the transmitted file name. If the print directory name is indicated
in the put command, the file name is not printed. The printer name printed is the logical
directory name.

Troubleshooting > 21



WEB BROWSER

To prevent your web browser caching the printer web pages, carry out the following steps
as appropriate for your web browser.

MICROSOFT INTERNET EXPLORER
1. Select Tools > Internet Options.
2. Select the General tab and, in Temporary Internet files, click Settings.

3. Under Check for newer versions of stored pages, seclect Every visit to the
page.
4. Click OK.

Settings E| FZ|

Check for newer versions of stored pages:
¥ (3) Every visit to the page
O Every time you start Internet Explorer
() automatically

O Mever

Tempoarary Internet files Folder

Current location:  Ci\Documents and SettingsilbyrneiLocal
Settingsi Temporary Internet Files)

Amount of disk space to use;

J = | uss g] we
[ Move Folder. .. ] [ ‘Wiew Files, .. ] [ Wiews Objects... ]
[ Ok ] [ Cancel ]

MOZILLA FIREFOX
1. In the Firefox address bar, type about:config.
In the Filter field, type frequency.

Double click on the entry browser.cache.check_doc_frequency.

h W N

Change the Value to 1.

> 0: Check once per browser session

> 1: Check every time I view the page

> 2: Never check (always use cached page)

> 3 (default): Check when the page is out of date (automatically determined)
5. Click OK.

%2 about:config - Mozilla Firefox
File  Edit  Wiew History Bookmarks  Tools  Help

¥ c {uy l |__1 about:config i

Filter: frequency

| Skatus
user set

Preference Name
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